Составить программу ( Паскаль) для 5 целых чисел, найти максимальное из них
P.S ТОЛЬКО с помощью If Then Else (должно быть коротко). Прошу помогите пожалуйста!!(

Var
n1,n2,n3,n4,n5:integer;
begin
Readln(n1,n2,n3,n4,n5);
If (n1>n2) and (n1>n3) and (n1>n4) and (n1>n5) then
writeln(Максимальное число: ,n1)
else If (n2>n1) and (n2>n3) and (n2>n4) and (n2>n5) then
writeln(Максимальное число: ,n2)
else If (n3>n1) and (n3>n2) and (n3>n4) and (n3>n5) then
writeln(Максимальное число: ,n3)
else If (n4>n1) and (n4>n3) and (n4>n2) and (n4>n5) then
writeln(Максимальное число: ,n4)
else
writeln(Максимальное число: ,n5);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку