Напишите программу, которая вводит возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год" "года" или "лет". Например "21 год" "22 года" "25 лет"
PascalABC.NET
var a:integer;
begin
read(a);
case a of 1,21,31,41,51,61,71,81,91,101:writeln(a, год); 2,3,4,22,23,24,32,33,34,42,43,44,52,53,54,62,63,64,72,73,74,82,83,84,92,93,94,102,103,104:writeln(a, года); 5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,25,26,27,28,29,30,35,36,37,38,39,40,45,46,47,48,49,50,55,56,57,58,59,60,65,66,67,68,69,70,75,76,77,78,79,80,85,86,88,89,90,105,106,107,108,109,110,115,116,117,118,119,120:writeln(a, лет);
end;
end.
Программа есть в приложении, просто скачай.
Оцени ответ
