Помогите пожалуйста! Написать программу , которая вычислит отдельные суммы четных и нечетных чисел натурального ряда и их произведения

Const
N = 7;
Var
A:array[1..N]of integer;
i:integer;
S,Sn,P,Pn:real;
Begin
S:=0;
Sn:=0;
P:=1;
Pn:=1;
For i:= 1 to N do
Begin
A[i]:=random(7)+1;
Write(A[i], );
if A[i] mod 2 = 0 then
Begin
S:=S+A[i];
P:=P*A[i];
End
else
Begin
Sn:=Sn+A[i];
Pn:=Pn*A[i];
End
End;
WriteLn;
WriteLn(Сумма чётных элементов =,S);
WriteLn(Произведение чётных элементов =,P);
WriteLn(Сумма НЕчётных элементов =,Sn);
WriteLn(Произведение НЕчётных элементов =,Pn);
End.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку