Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба
соседних элемента меньше данного.
Входные данные
Сначала задано число N — количество элементов в массиве (1N100). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо вывести количество элементов массива, у которых два соседа и которые при этом строго больше обоих своих соседей.
Примеры
Входные данные
5
1 2 3 4 5
Выходные данные
0
Входные данные
5
1 5 1 5 1
Выходные данные
2

Var
A:array[1..100]of integer;
N,S:byte;
Begin
Read(N);
For N:= 1 to N do
 Read(A[N]);
For N:= 2 to N-1 do
 if (A[N]>A[N-1])and(A[N]>A[N+1]) then S:=S+1;
Write(S)
End.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку