C++
Напишите программу, которая в последовательности целых чисел определяет разность максимального и минимального чисел. Программа получает на входе целее числа, количество введённых чисел неизвестно, последовательность чисел заканчивается число 0 (0 - признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30000.
Программа должна вывести одно число: разность максимального и минимального чисел.

#include
#include
using namespace std;
int main()
{
vector v (1000);
int max = -30000;
int min = 30000;
for (int i = 0; i <1000; ++i) {
cin >> v[i];
if (v[i] == 0) break;
if (v[i] >= max) max = v[i];
if (v[i] <= min) min = v[i];
}
cout << max -min <
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку