Требуется поменять местами первый элемент массива с максимальным.
ВХОДНЫЕ ДАННЫЕ
В первой строке вводится одно натуральное число, не превосходящее 1000 — размер массива. Во второй строке задаются N чисел — элементы массива (целые числа, не превосходящие по модулю 1000).
ВЫХОДНЫЕ ДАННЫЕ
Вывести получившийся массив. Если максимальных элементов несколько, требуется поменять первый из них.

Var a:array[1..1000] of integer;
n,i,im,max:integer;
begin
readln(n);
for i:=1 to n do
read(a[i]);
writeln;
max:=a[1];im:=1;
for i:=1 to n do
if a[i]>max then 
begin
max:=a[i];
im:=i;
end;
a[1]:=a[1]+a[im];
a[im]:=a[1]-a[im];
a[1]:=a[1]-a[im];
for i:=1 to n do
write(a[i], );
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку