Добрый день.
Помогите, пожалуйста, написать программу для вычисления суммы элементов арифметической и геометрической прогрессии.
{программу для вычисления суммы элементов арифметической прогрессии}
var i,j,q,d,n,s,s0,sm:integer;
begin
write(Введите число эле-в, первый элемент и шаг ариф. прогрессиии шаг);
read(n,s0,d);
for i:= 1 to n do begin
s:= s0 +(i-1)*d; write(s:2);
sm:= sm + s;end;
write(sm:4);end.
{программу для вычисления суммы элементов геометрической прогрессии}
var i,j,q,n:integer; z,b,b0,sm:real;
begin
write(Введите число эле-в, первый элемент и знаменатель геом. прогрессиии);
read(n,b0,q);
for i:= 1 to n do begin
z:=i;
b:= b0 *Power(q,z-1);
write(b:4);
sm:= sm + b;end;write(sm:4);end.
Оцени ответ
