Строки в Си Задан текст, состоящий из заглавных латинских букв и цифр. Определите, сколько раз каждая гласная буква встречается в тексте. Результат распечатайте в виде: Буква – количество. (гласные: A, E, I, O, U)

#include

int main()
{
char c;
int A = 0, E = 0, I = 0, O = 0, U = 0;

while ((c = getchar ()) != n)
switch (c) {
case A : {A++; continue;} ;
case E : {E++; continue;} ;
case I : {I++; continue;} ;
case O : {O++; continue;} ;
case U : U++;
}

printf ("A - %dnE - %dnI - %dnO - %dnU - %dn", A, E, I, O, U);

getchar ();

return 0;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку