
Помогите решить задачи по паскалю
1.Вычислить z(x)=sign(x)+sign(y)*sign(x+y)
Используя функцию
sign(x)=-1 если x<0
0 если x=0
1 если x>0
2.Написать процедуру для нахождения степени числа и вычислить значение выражения:x^5+x^4+x^8
3.Составить программу получения изображения в котором в 1-ой строке будет изображена 1*, во 2-ой строке 2*, в 3-ей строке 3*, в строке с номером m-m*.

1) var
x:integer;
begin
readln(x);
if x>0 then
writeln(1)
else if x<0 then
writeln(-1)
else
writeln(0);
end
Оцени ответ