
Помогите, пожалуйста, с паскалем!
Входные данные
Вводятся 2 числа: x и d.
Выходные данные
Подсчитайте и выведите одно число - сколько раз встречается в записи натурального числа x цифра d.
Примеры
входные данные
123
2
выходные данные
1
входные данные
141
1
выходные данные
2

Var
x,d,count:integer;
begin
write(x=);
readln(x);
write(d=);
readln(d);
while x>0 do
begin
if x mod 10 = d then
count:=count+1;
x:= x div 10;
end;
writeln(count);
end.
Оцени ответ