Помогите, пожалуйста, с паскалем!!!!!!!!!!!!!!!!!!!!!!
Входные данные
Вводится натуральное число x.
Выходные данные
Выведите сумму цифр числа x.
Примеры
входные данные
123
выходные данные
6
входные данные
102
выходные данные
3

Var
x,s:integer;
begin
write(x=);
readln(x);
    while x>0 do
    begin
        s:=s+(x mod 10);
        x:= x div 10;
    end;
    writeln(s=,s);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×