1) Какие из описаний могут быть именами переменных
a) 2a
b) summa
c) a2
d) сумма
2) Какая команда служит для ввода значений переменных в Pascal? Приведите пример.
3) Найдите и исправьте ошибки в следующей программе:
program a;
var a, b, c: integer;
begin
writeln(‘введите значения переменных a и b’);
read(a, b);
writeln((a+b+c)/3);
end.
4) Напишите программу для решения одной из двух задач:
a) Найти площадь трапеции с основаниями а и b и высотой h.
b) Найти значение выражения:
5) Напишите программу для нахождения суммы цифр трехзначного числа.

1) Б и С
2) read(a) ввод в переменную с клавиатуры. a:=значение просто присваивание 
3) 

program a1; 
var a, b, c: integer; 
begin 
writeln(введите значения переменных a и b); 
read(a, b); 
writeln((a+b+c)/3); 
end. 

Название программы и переменной были одинаковые. Так нельзя. Переименовал программу

4) б)

program znanija; 
var a, b, h: integer; 
begin 
writeln(Введите a, b и h); 
read(a, b, h); 
writeln(Площадь трапеции ,(a+b)/2*h); 
end. 

5)

program znanija; 
var a, b, i: integer; 
begin 

read(a);

for i:=1 to a do 
begin   
b:=b + a mod 10;   
a:=a div 10; 
end;  

writeln(b);
end. 

Работает не только для трёхзначных. Но и двух, трёх, четырёх и т.д.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку