
Пирожок в школьной столовой стоит a рублей и b копеек. Определите, сколько рублей и копеек нужно заплатить за n пирожков. Программа получает на вход три числа: a,b,n (0<=a<=1000, 0<=b<=99,1<=n<=1000) и должна вывести два числа: стоимость покупки в рублях и в копейках.
Пример
Ввод Вывод
10 20 30
15
2
----------------------
2 10 0
50
4

#include
#include
using namespace std;
void pie_price(int a, int b, int n)
{
assert((a >= 0) && (a <= 1000));
assert((b >= 0) && (b <= 99));
assert((n >= 1) && (n <= 1000));
double price = a * 1.0 + b / 100.0;
float res = price * n;
int kop = res * 100;
cout << "Rubles " << res << endl;
cout << "Kopeyks " << kop << endl;
}
int main()
{
int a, b, n;
cin >> a >> b >> n;
pie_price(a, b, n);
}
Оцени ответ