Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно

Входные данные: ввести два целых числа А,В (1<=A, B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

var

  sum, a, b, i : integer;

begin

  read (a, b);

  sum := 0;

  for i := a to b do //Бежим по всем числам от а до б

    sum := sum + i; //и прибавляем каждое число к сумме

  writeln (sum);

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку