Вывести все значения элементов заданной числовой последовательности.
Входные данные: Выходные данные:
Во входном потоке в первой строке записано единственное целое число N (0 < N <= 100) - число элементов числовой последовательности;
Во второй строке перечислены значения элементов целочисленной последовательности (через пробел). Значения элементов по модулю не превышают 1000.
В выходной поток вывести значения элементов числовой последовательности в столбик, каждое с новой строки.
Пример входного файла (input.txt):
10
43 564 32 76 342 76 43 342 876 42
Пример выходного файла (output.txt):
43
564
32
76
342
76
43
342
876
42
ПОМОГИТЕ ПОЖАЛУЙСТААА!!

Не знаю, на каком языке ты программируешь... я написал на C#
 using System;
namespace ConsoleApplication55{    class Program    {        static void Main(string[] args)        {            link:            Console.Write("Введите кол-во элементов  числовой последовательности: ");            int kol = Convert.ToInt32(Console.ReadLine());            if (kol > 100 || kol < 0)                goto link;            Random ran = new Random();            int[] array = new int[kol];            Console.WriteLine("nПоследовательность чисел в строчку: ");            for (int i = 0; i < array.Length; i++)            {                array[i] = ran.Next(1, 1000);                Console.Write(array[i] + " ");            }            Console.Write("nnПоследовательность чисел, где каждое с новой строки:n");            for (int i = 0; i < array.Length; i++)                Console.Write(array[i] + "n");            Console.ReadKey();        }    }}
Смысл такой: ты делаешь массив, размер которого указываешь в начале, потом загружаешь  него рандомные(случайные) числа с периодом от 1 до 1000. После этого выводишь с помощью цикла for элементы с условием, что после каждого элемента будет перевод строки(в С# это "n"), в Паскале это writeln и т.д.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×