Всем привет ) помогите с паскалем
В городе началась мода на модные номера мобильных телефонов. Модным считается номер, в котором 4 или больше из 7 цифр одинаковые. Помогите жителям определить является ли номер модным.
Входные данные:
Вводится единственное число, состоящее ровно из 7 цифр. Причём известно, что номер не начинается с 0.
выходные данные: Вывести YES- если номер модный и NO в противном случае.

Var N : Longint;

Function Check(A : Longint) : Boolean;
Var
  m : array[0..9] of Byte;
  i : Byte;
Begin
  For i:=0 to 9 do m[i]:=0;
  While A>0 do
  Begin
    Inc(m[A mod 10]);
    A:=A div 10;
  end;
  Check:=False;
  For i:=0 to 9 do If m[i]>=4 then Check:=True;
end;

Begin
  N:=0;
  While (N<1000000) or (N>9999999) do Readln(N);
  If Check(N) then Writeln(YES) else Writeln(NO);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку