Составить программу в паскале для вычисления величины S по формуле:

//PascalABC.Net 3.0, сборка 1053
const
  n=20;
  m=15;
var
  i:integer;
  xi,yj,s,p:real;
begin
  Randomize;
  s:=0;
  for i:=1 to n do
    begin xi:=12*Random-6; s:=s+cos(sqr(xi)) end;
  p:=1;
  for i:=1 to m do
    begin yj:=12*Random-6; p:=p*sin(yj) end;
  Writeln(s=,exp(-s)+exp(p))
end.
 
Тестовое решение:
s=1.50376271681269

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку