Дан числовой массив А, состоящий из n натуральных чисел. Определите количество элементов массива, которые при делении на 7 дают остаток 1, 2 или 5.
Const
N = 7;
Var
A:array[1..N] of integer;
i,j:integer;
Begin
j:=0;
WriteLn(Введи массив A(N));
For i:= 1 to N do
Begin
Read(A[i]);
if (A[i] mod 7 =1)or(A[i] mod 7 =2)or(A[i] mod 7 =5) then j:=j+1
End;
WriteLn(j)
End.
Оцени ответ
