Составить программу решения ах2+вх+с=0,а,в не равно нулю.Проверить случай ,когда дискриминант болmше нуля меньше нуля и равен нулю.


 program ii;  
                var A, B, C, D: real; 
                  begin   
  writeln (Введите коэффициенты А, В, С); 
   readln (A, B, C);   
  if A=0     then
 writeln (Уравнение не квадратное)
     else
begin
 D := B*B - 4*A*C; 
A := 2*A;
if D<0 then
writeln (Действительных корней нет)
else
 if D=0 then
writeln (Корни равны: X1 = X2 = , -B/A)
else 
   begin       
  D := sqrt(D);      
    writeln (X1 = , (-B+D)/A);writeln (X2 = , (-B-D)/A); 
  end;        end;              end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку