1.Составить программу максимума из двух чисел.
2.Составить программу вычисления наибольшего из четырех чисел с использованием процедуры определения наибольшего из двух чисел.
1) program p1;
var a,b:integer;
begin
writeln(Введите 1-е число: );read(a);
writeln(Введите 2-е число: );read(b);
if(a>=b) then writeln(максимальное число: , a) else writeln(максимальное число: , b);
end.
2)
program p1;
procedure MaxNumber(a,b: integer; var max: integer);
begin
if a>=b then max:=a else max:=b;
end;
var a,b,c,d,m:integer;
begin
writeln(Введите 1-е число: );read(a);
writeln(Введите 2-е число: );read(b);
writeln(Введите 3-е число: );read(c);
writeln(Введите 4-е число: );read(d);
MaxNumber(a,b,m);
MaxNumber(m,c,m);
MaxNumber(m,d,m);
writeln(максимальное число: ,m);
end.
Оцени ответ
