Pascal ABC. Написать программу, которая находит сумму четных элементов массива произвольного размера (размер и элементы массива вводятся с клавиатуры).

Var
  a:array of integer;
  i,b,c:integer;

BEGIN
  write(Введите размер массива - );
  readln(b);
  setlength(a,b);
  writeln(Введите элементы массива - );
  for i:=0 to b-1 do begin
    readln(a[i]);
    if a[i] mod 2 = 0 then c:=c+a[i];
  end;
  writeln(Сумма четных элементов массива  - ,c);
END.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку