Помогите решить задачу по информатике. Нужно очень срочно
Составить программу на паскале. найти среднее значение элементов двумерного массива и подсчитать, сколько в этом массиве элементов, превышающих среднее значение.
USES CRT;
VAR A:array[1..3,1..3] of integer;
i,j,s,summa:integer;
sred:real;
BEGIN
CLRSCR;
Randomize;
summa:=0;
s:=0;
{Заполняем массив случайными числами от 0 до 15 и выводим на экран}
For i:=1 to 3 do
begin
For j:=1 to 3 do
begin
A[i,j]:=Random(15);
Write( ,A[i,j]:2, );
end;
Writeln;
end;
{находим общую сумму всех элементов массива }
For i:=1 to 3 do
For j:=1 to 3 do
begin
summa:=summa+A[i,j];
s:=s+1;
end;
Writeln;
Writeln( ,summa, ,s);
Writeln;
{Находим средне арифметическое число массива}
sred:=summa/s;
Writeln( ,Средне арифметическое = ,sred:2:1);
s:=0;
{считаем количество элементов превышающих среднее значение}
For i:=1 to 3 do
For j:=1 to 3 do
if sred
Writeln;
Writeln( ,s, элементов массива превышающие средне арифметическое);
READLN;
END.
