Составить программу для вычисления величины S по формуле:
S=2(Σ^20[i=1]*cos(b^2[i])+e^^10[k=1]*z[k])
program p5_4;
var
P,S,S1:real; i,k:integer;
b:array[1..20] of integer;
z:array[1..10] of integer;
begin
writeln( z: );
for k:=1 to 10 do
begin
z[k]:=random(11)-5;
write(z[k]:4);
end;
writeln;
writeln( b: );
for i:=1 to 20 do
begin
b[i]:=random(11)-5;
write(b[i]:4);
end;
P:=1;
S1:=0;
for i:=1 to 20 do
S1:=2*(S1+cos(sqr(b[i])));
for k:=1 to 10 do
P:=P*(z[k]);
S:=S1+P;
writeln( S=,S:2:5);
end.
Нам преподаватель сказал сделать без команды random, а я не пойму как она здесь будет выглядеть без random, так же и другая задача(((((

Без рандома:

program p5_4;
var
P,S,S1:real; i,k:integer;
b:array[1..20] of integer;
z:array[1..10] of integer;
begin
writeln( z: );
for k:=1 to 10 do
begin
Readln(z[k]);
write(z[k]:4);
end;
writeln;
writeln( b: );
for i:=1 to 20 do
begin
Readln(b[i]);
write(b[i]:4);
end;
P:=1;
S1:=0;
for i:=1 to 20 do
S1:=2*(S1+cos(sqr(b[i])));
for k:=1 to 10 do
P:=P*(z[k]);
S:=S1+P;
writeln( S=,S:2:5);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку