ПОМОГИТЕ ПОЖАЛУЙСТА! Даю очень много баллов!
ПОЖАЛУЙСТА НЕ КОПИРУЙТЕ С ДРУГИХ САЙТОВ, ТАМ НЕ ПРАВИЛЬНО! И дочитайте текст до конца пожалуйста!
Уличный продавец получает a рублей с продажи каждой из первых 50 газет. С продажи каждой из последующих газет он получает на 20% больше. Вычислите дневной заработок продавца, продающего k газет в день.
НУЖНО СОСТАВИТЬ ПРОГРАММУ ПАСКАЛЬ ДЛЯ ВЫЧИСЛЕНИЯ ДНЕВНОГО ЗАРАБОТКА ПРОДАВЦА, ГДЕ a И b НУЖНО ВВОДИТЬ САМОЙ. Если вы не можете составить программу, то помогите пожалуйста хотя бы написать уравнение решения этой задачи, ведь тогда a и k остаются как есть. Пожалуйста, очень прошу помочь!

Var i,k: integer;
    a,an,s: real;
begin  write(стоимость газеты из первых 50:  );    readln(a);
  write(число проданных газет:  );
  readln(k);
  writeln; 
  if k<=50 then s:=k*a
  else
  begin 
    s:=50*a;
    an:=a;
    for i:=1 to k-50 do
    begin
      an:=an*1.2;
      s:=s+an;
    end;
  end;
  writeln(продано газет  ,k,  выручка составила  ,s, руб.);
  end.
 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку