составить программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 20 и находит минимальный элемент массива и его индекс

var 

  a: array [1..10] of integer;

  i, min, MinIndex: integer;  {min - значение минимального элемента массива, MinIndex - индекс минимального элемента массива}

 

begin

  min:= 20;

  write(Исходный массив:  );

  for i:= 1 to 10 do

  begin

    a[i]:= random(19) + 1;

    write(a[i],  );

    if a[i] < min then 

    begin

      min:= a[i]; 

      MinIndex:= i;

    end;

  end;

  writeln;

  write(Минимальный элемент массива:  a[, MinIndex, ] = , min);

  writeln;

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку