Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое трёхзначных чисел или вывести «NO», если таких чисел нет

Var i,b,c:integer;
a:array[1..100] of integer;
Begin
Read(b);
I:=1;
While b<>0 do
Begin
A[i]:=b;
I:=i+1;
Read(b);
End;
C:=i-1;
D:=0;
B:=0;
For i:=1 to c do
If a[i]>99
Then begin b:=b+a[i]; d:=d+1; end;
If b=0
Then writeln(NO)
Else writeln(b/d);
End.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку