Программирование алгоритмов ветвления
Для заданного преподавателем варианта задания составьте программу, которая
вычисляет значение выражения Входные данные: x, y – переменные вещественного типа.
Все входные данные вводятся с клавиатуры. Выходные данные: z – переменные
вещественного типа. Все выходные данные выводятся на экран монитора.
В c++

#include
#include

using namespace std;

int main() {
    float x, y, z;
    cin >> x >> y;
    if (x <= 0) {
        z = pow(3 * pow(x, 5) + y * y, (float) 1 / 7);
    } else if (x > 0 && abs(y) >= x) {
        z = atan(x * y);
    } else {
        z = log(5 * x - abs(y)) / log(4);
    }
    cout << z;
    return 0;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку