Составить программу "Вычисление площади прямоугольника ,если заданы координаты 3-х его вершин"

Var x1,y1,z1,x2,y2,z2,x3,y3,z3,abx,aby,abz,acx,acy,acz,s,mx,my,mz,c:real;
begin;
readln(x1);
readln(y1);
readln(z1);
readln(x2);
readln(y2);
readln(z2);
readln(x3);
readln(y3);
readln(z3);
abx:=x2-x1;
acx:=x3-x1;
aby:=y2-y1;
acy:=y3-y1;
abz:=z2-z1;
acz:=z3-z1;
mx:=aby*acz-abz*acy;
my:=abz*acx-abx*acz;
mz:=abx*acy-aby*acx;
c:=sqrt(sqr(mx)+sqr(my)+sqr(mz));
s:=0.5*c;
writeln(s);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку