Составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10,затем преобразовывает его, увеличивая все элементы с чётными значениями на 1. Если элементы с чётными значениями отсутствуют, оставить массив без изменений.
//Pascal ABC.NET Версия 2.2 Сборка 790
var ar:array[1..10] of integer;
i:integer;
begin;
randomize;
writeln(First array);
for i:=1 to 10 do
begin;
ar[i]:=random(1,10);
writeln(ar[i]);
if ar[i] mod 2=0 then inc(ar[i]);
end;
writeln(Final array);
for i:=1 to 10 do
writeln(ar[i]);
end.
Пример вывода:
First array
3 3 4 10 10 4 6 9 6 7
Final array
3 3 5 11 11 5 7 9 7 7
Оцени ответ
