Помогите написать программу на C++
Дана символьная строка, представляющая собой запись натурального числа в р-ичной системе счисления (2 ≤ р ≤ 9). Составить программу перевода этого числа в десятичную систему счисления. Используя рекурсию.
Заранее благодарю)

//перевод числа из системы исчисления
//с основанием от 2 до 9 в десятичную
 #include
#include
#include
using namespace std;
  int pss(char sr[80], int i, int osn)
  { 
    static int s;
    char ch=sr[i-1];
    if (i==strlen(sr)) s=1;
    s=s*osn;
    if (1    else return (atoi(&ch)); 
 }
int main(int argc, char** argv)
 { 
    int osn=0;
    char st[80];
    cout<<" задайте основание (от 2 до 9)  ";
    cin>>osn;  cout<    cout<<"число:  "; cin>>st;   cout<    cout<<"в десятичной системе:  "
     <    return(0);
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку