99 баллов
Вводится последовательность из Nнатуральных чисел. Необходимо определить наименьшее натуральное число, отсутствующее в последовательности.
Формат входного файла
В первой строке указано число N, 0 Формат выходного файла
Вывести наименьшее число, отсутствующее в последовательности.
Пример
Var
i,n,k:integer;
A: array of integer; // Динамический массив
flag:boolean;
begin
Assign(input,input.txt);
Assign(output,output.txt);
Reset(input); //input и output - зарезервированные слова в PascalABC
Rewrite(output);
Readln(n);
SetLength(A,n+1);
for i:=1 to n do
read(A[i]);
close(input);
flag:=true;
i:=1;
while (flag and (i
inc(i);
if (abs(A[i-1]-A[i])<>1)
then begin
flag:=false;
k:=i;
end;
end;
if not (flag) then writeln(A[k-1]+1)
else if A[1]>1 then writeln(A[1]-1);
close(output);
end.
Оцени ответ
