Дана строка, состоящая из 50 символов. Составьте программу, используя процедуру которая определяет сколько раз встречается в строке слог ‘ea’.

Var s:string;k:integer;

procedure SubInc(var s:string;var k:integer);
begin;
while pos(ea,s)<>0 do
begin;
delete(s,pos(ea,s),2);
inc(k);
end;
end;

begin;
readln(s);
if length(s)<>10 then exit;
SubInc(s,k);
writeln(k);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку