Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет среднее арифметическое элементов этого массива.
Входные данные
Входная строка содержит три числа: границы диапазона случайных чисел A и B , а также размер массива N . Все числа разделены пробелами. Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
В первой строке программа должна вывести N элементов построенного массива, разделив их пробелами, а во второй строке – среднее арифметическое элементов этого массива, сохранив три знака в дробной части.

Var
c:array[1..100] of integer;
i, n, k, S, a, b: integer; q: real;
begin
read(n); read(a); read(b); k:=0; S:=S;
for i:=1 to n do  begin
a[i]:=random(a,b);
k:=k+1; S:=S+a[i]; write(a[i],  );    end;
q:=S/k;
writeln(q:17:3);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку