1)Как блок-схемой и на алгоритмическом языке представляется команда с предусловием?
2)Как программируется цикл с предусловием на Паскале?
3)Почему алгоритм вычисления N! должен быть циклическим?
4)Из каких этапов состоит работа программиста по решению задачи на компьютере?
5)Что такое математическая формализация задачи?
6)Что такое отладка программы ?Что называется тестом?

1. ромб, только стрелка вниз если условие сохраняется, стрелка в права, если условие нарушено, и слева приход при следующем цикле. (или наоборот) см рисунок

2. while i <= n do begin
        write ((*) );
        i := i + 1
    end;

3. потому что необходимо перебрать всезначения от 1 до N

4. постановка задачи;математическая формализация; построение алгоритма; составление программы на языке программирования; отлад­ка и тестирование программы; проведение расчетов и анализ полученных результатов.

5. описательная информационная модель записывается с помощью какого-либо формального языка

6. отладка это испытание с исправлением ошибок, тест это окончательный прогон с конкретным значением данных для которых известен результат.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку