Даны целое трехзначное число N и цедое число k. написать программу, подсчитывающую сумму цифр числа N, которые больше k

Var N,k,sum : Integer;
Begin
  sum:=0;
  Readln(N,k);
  While N>0 do
  Begin
   If (N mod 10)>k then sum:=sum+(N mod k);
   N:=N div 10;
  end;
end.

или так

Var N,k,sum : Integer;
Begin
  sum:=0;
  Readln(N,k);
  While N>0 do
  Begin
   sum:=sum+(N mod 10)*Ord((N mod 10)>k);
   N:=N div 10;
  end;
end.

или так

Var N,k : Integer;
Function sum(N,k : Integer) : Integer;
Begin
  If (N>0) and ((N mod 10)>k) then sum:=(N mod 10)+sum(N div 10,k) else sum:=0;
end;
Begin
  Readln(N,k);
  Writeln(sum(N,k));
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку