Напишите программу которая определяет является ли число простым.

Program PrimeNumber;

Uses Crt;

var i,f,n:integer;
begin

     clrscr;
      write(Введите число:);
      readln(n);

      f:=0;  
      for i:=2 to trunc(sqrt(n)) do
              if (n mod i)=0 then f:=1;
      if (f=0) then writeln(Число является простым)

                     else writeln(Число не является простым);
      readkey;
end.

 

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку