Напишите программу,которая в последовательности целых чисел определяет их сумму и количество чётных чисел,кратных 5.
Четное число делится на два, а кратное пяти делится на пять, поэтому число должно делиться без остатка на 2х5=10
// PascalABC.NET 3.0,сборка 1076
begin
var n:=ReadInteger(Длина последовательности: );
var a:=ArrRandom(n,-50,50);
Writeln(Исходная последовательность);
a.Println;
Writeln(Сумма элементов: ,a.Sum);
Write(Кол-во четных, кратных пяти: );
Writeln(a.Where(x-> x mod 10 = 0).Count)
end.
Тестовое решение:
Длина последовательности: 20
Исходная последовательность
-4 21 -21 -23 14 -39 -12 1 -7 4 17 -45 30 -48 -19 -12 27 -46 -37 15
Сумма элементов: -184
Кол-во четных, кратных пяти: 1
Оцени ответ
