Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
Входные данные-(Входная строка содержит два целых числа.) Выходные данные-(Программа должна вывести произведение введённых чисел.)
Примеры входные данные-(6,12) выходные данные-(72) РЕШИТЬ В ПАСКАЛЬ АБЦ
Var
a,b,x,y,z:integer;
begin
writeln(Введите первое число);
readln(a);
writeln(Введите второе число);
readln(b);
z:=b;
if b<0 then z:=-b;
for y:=1 to z do begin
x:=x+a;
end;
if b<0 then x:=-x;
writeln(Произведение чисел = ,x);
end.
Проверка по входным данным на фото
Оцени ответ
