1. Дано целое число А. Если значение А > 0, то необходимо увеличить его на единицу, иначе уменьшить на 1. Написать программу для решения этой задачи. Программа должна иметь дружественный интерфейс. Протестировать программу для A=3, A=0, A=-12.
2. Даны два действительных числа X и Y, не равные друг другу. Заменить меньшее из этих чисел половиной их суммы, а большее – их удвоенным произведением. Программа должна иметь дружественный интерфейс.
Программы На Паскале, прошу, помогите.
1.
Var A : Integer;
Begin
Write(Введите число A: ); Readln(A);
If A>0 then A:=A+1 else A:=A-1;
Writeln(Новое значение числа A: ,A);
end.
2.
Var A,B,c : Real;
Begin
Write(Введите число A и B: ); Readln(A,B);
c:=(A+B)/2;
If A Begin
B:=A*B*2;
A:=c;
end else
Begin
A:=A*B*2;
B:=c;
end;
Writeln(Новые значения A и B: ,A:6:2,B:6:2);
end.
Оцени ответ
