Составьте программу,которая заполняет массив а[1..10] случайными целыми числами в диапазоне от -12 до 12 и выводит на экран количество положительных чисел и их значения
Const
n=10;
var
a:array[1..n] of integer;
i,e:integer;
begin
e:=0;
writeln(Исходный массив);
for i:=1 to n do
begin
a[i]:=random(24)-12;
write(a[i], );
end;
writeln;
writeln(Положительные числа);
for i:=1 to n do
if a[i]>0 then
begin
write(a[i], );
e:=e+1;
end;
writeln;
writeln(Кол-во положительных элементов ,e);
end.
ТЕСТ
Исходный массив
-10 -6 5 5 0 -1 3 -2 6 -9
Положительные числа
5 5 3 6
Кол-во положительных элементов 4
Оцени ответ
