Требуется посчитать сумму целых чисел от 1 до N.
Входные данные
В единственной строке входного файла INPUT.TXT записано единственное целое число N, не превышающее по абсолютной величине 104.
Выходные данные
В единственную строку выходного файла OUTPUT.TXT нужно вывести одно целое число — сумму чисел от 1 до N.

Var
f1,f2:text;
n,i,s:integer;
begin
assign(f1,INPUT.TXT);
assign(f2,OUTPUT.TXT);
reset(f1);
rewrite(f2);
readln(f1,n);
s:=0;
for i:=1 to n do
s:=s+i;
writeln(f2,s);
close(f1);
close(f2);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку