Free Pascal. Нужно написать программу, где после каждой буквы Ch вставляется строка Str1.
program Project4;
var ch:char; str,str1,str2:string; i:integer;
begin
writeln(Введите исходный текст:);
readln(str);
writeln(Введите строку которую нужно вставить:);
readln(str1);
writeln(Введите символ после которого нужно вставить:);
readln(ch);
str2:=;
i:=pos(ch,str);
while i>0 do begin
str2:=str2+copy(str,1,i)+str1;
delete(str,1,i);
i:=pos(ch,str);
end;
writeln(Результирующая строка: ,str2);
readln;
end.
Оцени ответ
