Паскаль. Составить программу вычисления площади треугольника по любой из 3 известных формул(в программе должны использоваться все 3 на выбор).

Сами формулы:

1.S=ah/2

2.S=1/2ab sin C

3.S=sqrt(p(p-a)(p-b)(p-c))

Очень прошу пишу уже 2-ой раз!

var S,a,b,c,p,p1,h:real;
k:integer;
begin
write(Kakoy sposob viberem(1,2,3)?);
read(k);
if k=1 then begin
writeln(Vvedite a,h);
read(a,h);
S:=(a*h)/2;
end;
if k=2 then begin
writeln(Vvedite a,b,c);
read(a,b,c);
S:=(Sin(c*Pi/180)*a*b)/2;
end;
if k=3 then begin
writeln(Vvedite a,b,c);
read(a,b,c);
p1:=1/2*(a+b+c);
S:=sqrt(p1*(p1-a)*(p1-b)*(p1-c));
end;
writeln(S);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку