Дана строка ,содержащее слово,записанное через дефис. написать программу ,которая вставляет пробелы перед и после дефиса. помогите пожалуйста!

Var s: string;
    i: integer;
begin
   write(строка:  );
   readln(s);     i:=1;
   while i<=length(s) do
   begin
     if s[i]=- then
     begin
       s:=copy(s,1,i-1)+ +s[i]+ +
       copy(s,i+1,length(s)-i+3);
       i:=i+2;
    end;
    i:=i+1;
  end;
  writeln(новая строка:  ,s);
end.
    

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку