Напишите программу,в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор,пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.

Var pos,neg,i: integer;
begin
  pos:=0;  neg:=0;
  i:=1;
  while i<>0 do
  begin
    readln(i);
    if i>0 then pos:=pos+1
    else neg:=neg+1;
  end;
  writeln(число положительных чисел = ,pos);
  writeln(число отрицательных чисел = ,neg);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку