Помогите написать программу на Си. Дана строка. Преобразовать в ней все строчные буквы (как латинские, так и русские) в прописные, а прописные — в строчные.

#include
#include
using namespace std;
int main(){
//---------------------
char S[256];
cin >> S;

int i,n;

n=strlen(S);

for(i=0;i<=n;i++){

if (isupper(S[i])==true){

S[i]=tolower(S[i]);

}else{

S[i]=toupper(S[i]);
}
}
cout << S;
//---------------------
return 0;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку