1.Составить программу в паскале,которая предлагает Ивану -Царевичу выбрать правильное направление пути.У Ивана-Царевича есть три варианта дальнейшего пути:
направо,-"Коня потеряешь"
налево,-"голову сложишь"
вперёд,-"невесту найдёшь"
2.Составить прогрмму,которая определяет положительное число или отрицательное.
3.Дано целое число А.Если значение А>0,то необходимо его уыеличить на единицу.Если В<0,то уменьшить на единицу.
Зарание спасибо :)
program cvdcnio
uses crt;
var a:string;
begin
clrscr;
case a of
Направо:writeln(Коняш);
Налево: writeln(Голова);
Вперед: writeln(Невестка);
readln
end.
program fcndkjn;
uses crt;
var a:integer;
begin
clrscr;
readln(a);
if a>0 then writeln(+) else writeln(-);
readln;
end.
program fmc;
uses crt;
var a:integer;
begin
clrscr;
readln(a);
if a>0 then writeln(a+1) else writeln(a-1);
readln;
end. Надеюсь тут в условии, не b<0, а a<0
