Помогите пожалуйста решить!
Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат. Запишите решение с помощью оператора boolean.

Var x1,y1,x2,y2:integer;
p1,p2:real;
b:boolean;
begin;
readln(x1);
readln(y1);
readln(x2);
readln(y2);
p1:=sqrt(sqr(x1)+sqr(y1));
p2:=sqrt(sqr(x2)+sqr(y2));
if p1>p2 then b:=true else b:=false;
writeln(b);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку