Дано натуральное число.
Верно ли, что количество его цифр есть четное число, а само число не превышает b ?
Написать программу на паскале используя циклы, но не используя массивы, строковый тип и boolean

Var i,n,k,b: integer;
begin
  write( b = );  readln(b);
  write( n = );  readln(n);
  i:=n;  k:=0;
  while i>0 do
   begin
    i:=i div 10;    k:=k+1;
  end;
  if n<=b then writeln(число n не превышает ,b)
  else writeln(число n больше ,b);
  if (k mod 2) = 0 then writeln(число цифр = ,k, - четное)
  else writeln(число цифр ,k, - нечетное);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку