В программе Алго, напишите программу для нахождения произведения цифр натурального числа N, введенного с клавиатуры.
Программа написана на языке программирования Pascal
program z1;
var N,p,n1,i:integer;
begin
writeln(Введите число N);
readln(N);
p:=1;
for i:=1 to n do
if N>0
then begin n1:=N mod 10 ; p:=p*n1; N:=N div 10; end;
write(Произведение=,p);
end.
Оцени ответ
